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Abstract 

Within four steps: Start → Basemaps → Mapping → Layouts, this tutorial serves as a guide for geologists 

on how to create a digital, geological map with the open source GIS program QGIS 3. The tutorial is made 

for students and unexperienced users. 

After a general overview, the first step gives instructions on the download and installation of the program 

and on coordinate reference systems. The second step explains how to implement different basemap 

layers as a mapping background. In the third step, the actual mapping is done by adding points, lines and 

polygons to the map. The last step shows how to create a printable map layout with elements like a 

coordinate grid, a north arrow, a scale bar etc. 

The herein presented way of producing a geological map with QGIS is only one possibility and every user 

is encouraged to learn by exploring and playing with the numerous functions of the program! 

 

Figure 1, The final geological map as produced during the tutorial 
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Introduction 

QGIS is an open source, freely available geographical 

information system (GIS) that is licensed under the 

Creative Commons Attribution-ShareAlike 3.0 license. It 

provides an ever-increasing number of tools to create, 

edit and visualize geospatial data (QGIS Development 

Team, 2018).  

An in-depth description and further information about 

the program and its functions is given in the official QGIS 

documentation. Button icons were taken from there as 

well: 

https://www.qgis.org/en/docs/index.html 

This tutorial is a step by step instruction on how to create 

a geological map with QGIS. As an example for a mapping-

project, a very simplified geological map of a small part of 

the Karwendel mountain range North of Innsbruck (Tyrol 

/ Austria) will be created. No geological research goal is 

pursued and the author does not guarantee for the 

correctness of the presented geological data. The final 

map is given in Figure 1. 

Additional background information to certain topics will be given 
between blue lines, in italic, blue letters like this sentence. 

Useful tips will be given in italic, dark red letters like this sentence.  

This tutorial is made for the windows based version of 

QGIS. 

 

1. Step: Start 

1.1. Download and Installation 

The open source geographical information system QGIS 

can be downloaded for free from: 

https://www.qgis.org → Download Now. 

On the following page you can choose the version that 

suits you best. This tutorial was designed for QGIS 3.0.1. 

Figure 2; QGIS graphical user interface: 1. Menu bar, 2. Toolbars, 3. Panels, 4. Map window, 5. Status bar 

https://www.qgis.org/en/docs/index.html
https://www.qgis.org/
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Depending on your operating system (OS), you can 

choose the 32bit- or 64bit- version of the program (usually 

you’d pick the 64bit version if you are using a 64bit OS, but some 

plugins are only working with the 32bit version of QGIS). 

Follow the installation assistant step by step. At the end 

of the installation, a folder will be created on your 

desktop (or wherever you choose to save QGIS) which 

contains a link to the program “QGIS Desktop 3.0.1”. → 

Double Click to launch. 

1.2. Program Start – New Project 

After initializing the program, you will see the QGIS 

graphical user interface (GUI) (Figure 2). The GUI is highly 

customizable. E.g.: by right clicking the toolbar, or via 

View → Toolbars, you can add additional tools and panels 

to the GUI. For this tutorial, it is recommended to add the 

“Advanced Digitizing Toolbar”, the “Manage Layers 

Toolbar” and the “Snapping Toolbar”. 

To start a new project, press the New button  on the 

upper left side of the toolbars. 

Generally, the mapping functionality of QGIS is based on 

a stack of layers with different kinds of data and 

information. Before starting a new project, you should 

give some thought to the order of these layers. This will 

help to keep your project neat and well organized! For 

this tutorial the data structure of Table 1 will be used. 

Table 1; data-structure used in this tutorial 

order layer datatype 

 
TOP 

 
 
 
 
 
 

BOTTOM 

point signatures 
(e.g. orientation 
data) 

points 
(shapefiles) 

line signatures (e.g. 
faults) 

lines 
(shapefiles) 

distribution of 
geologic units 

polygons 
(shapefiles) 

basemaps (e.g.: 
pre-existing maps, 
terrain data) 

rasters, 
web map 
servers… 

It is recommended to store all files of the project in an 

organized folder structure. For this tutorial, the simple 

folder structure of Figure 3 will be used. The project itself 

is saved  into a designated folder which contains two 

separate folders for raster- and vector-data. 

Well organized layer- and folder structures will save you lots of work 
(and headaches) later. 

 

Figure 3; a simple folder structure for this tutorial 

1.3. Coordinate Reference Systems 

By default, the coordinate reference system (CRS) is set 

to WGS 84 (EPSG: 4326). The actual CRS can be seen on 

the right side of the Status bar. By clicking this CRS symbol 

or by Project → Project Properties → CRS you can switch 

between different CRSs. QGIS3 shows you a preview of 

the CRS boundaries. This allows you to check whether you 

have selected a valid system (Figure 4).  

 

Figure 4; You can switch coordinate reference systems (CRS) easily 
within the Project Properties. As a new feature, QGIS3 gives you a 
preview of the CRS boundaries. 
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2. Step: Basemaps 

The first step for the creation of a digital geological map 

by QGIS is to add a basemap to the project. It serves as 

the “background” on which new, individual information is 

presented. Basemaps can for example be scanned, old 

geological maps, digital geological maps, topographical 

maps, rasterized terrain data etc. Before adding data, 

Right Click into the Layers Panel and press Add Group 

. Call this group “basemaps” and insert all basemaps 

you want to use. In case of numerous basemaps, subgroups may 

help to keep the project organized. Data-sources of this tutorial 

can be found in Appendix 1. 

2.1. Raster data 

2.1.1. Adding raster data 

The digital elevation model (DEM) of Tyrol with a 5m 

resolution (provided by Land Tirol (2018)- data.tirol.gv.at 

for free) will here be used as the main basemap (data 

source: Appendix 1) . 

Clear definitions of digital terrain/elevation/surface model (DTM, 
DEM, DSM) are controversial (Li et al., 2005). An old definition of a 
DTM is given by Miller and Laflamme (1958):  

“The digital terrain model (DTM) is simply a statistical representation 
of the continuous surface of the ground by a large number of selected 
points with known X, Y, Z coordinates in an arbitrary coordinate field.” 

In this tutorial DEM – in contrast to DSM - refers to raster data that 
represents the ground surface without vegetation and buildings. 

The easiest way to add raster data, is to “drag and drop” 

the raster file from its folder into the map window. 

Alternatively, you can press the Add Raster Layer button 

 in the Manage Layers Toolbar. In the following 

window, choose the raster file’s location on your 

computer and press Add. 

By adding raster files like the 

“DGM_Tirol_5m_epsg31254.tif”, QGIS automatically 

switches the project CRS to the raster file’s CRS which in 

this case is the “MGI / Austria GK West” (EPSG: 31254).  

2.1.2. Clipping raster data 

 

Figure 5; Settings for the "Clip raster by extent" tool 

Due to the high resolution and size of the used raster file 

it is computationally very demanding. Therefore, the next 

step is to clip the part of the project area from the raster 

(i.e.: to crop all unnecessary parts of the raster file). In the 

Menu bar choose Raster → Extraction → Clip raster by 

extent. In the following window, choose the correct 

“Input Layer” and the folder path where you want to save 

the clipped raster. Click the button next to the field 

“Clipping extent” (1 in Figure 5) and choose Select extent 

on canvas. After you have chosen the desired extent on 

the map window by dragging a frame around it, click Run 

in Background. You will find the clipped part of the raster 

as a new layer “Clipped (extent)” in your layers panel. The 

new layer is only a temporary layer. To save it permanently, Right click 

it and choose Save as. Within the Save Raster Layer as… window you 

can select different file types (choose the default GeoTIFF) and change 

the CRS of the new layer.  

2.1.3. Hillshade, slope, contour lines 

By default, QGIS chooses a “singleband gray” rendering 

to display raster data. This style colorizes the raster layer 

with a black to white gradient from the lowest to the 

highest point which is sometimes not the graphically 

most appealing and informative style. By choosing Raster 

→ Analysis → Hillshade from the Menu bar you can add 



 

7 

a raster layer with a shaded view of the terrain which is a 

more three-dimensionally looking style (Figure 7). 

Apply different azimuths and altitudes of the light to your DEM and 
see how the visibility of morphologies changes under different light 
angles. 

Another option is the “slope” view which assigns a 

(continuous) colorband or discrete colors to the raster 

layer depending on its steepness. Raster → Analysis → 

Slope 

Extracting contour lines is possible by clicking Raster → 

Extraction → Contour. Choose the desired “Interval 

between contour lines”. 

When using these raster tools, always check whether the correct 
raster layer is chosen in the Input Layer field. A wrong input can 
easily lead to weird output and extended computing time. 

Right click a new layer within the layer panel and select 

Properties. Choose from a wide range of customization 

options for styling your layers.  

By now, your project should look approximately like 

Figure 6. 

 

Figure 7; Calculating a Hillshade view from a DEM 

 

2.2. Web Map Service 

Web map service (WMS), web feature service (WFS) or web coverage 
service (WCS) are possibilities to access and implement layers of 
geographic information from remote servers, without the need of 
storing additional data on your computer.  

Figure 6; QGIS GUI with some toolbar - and panel customizations (compared to Figure 2). A DEM with “Hillshade” style has been added and 
contours with a spacing of 20m were extracted from the DEM. 
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Web Map Services (WMS) constitute an additional data-

source. By pressing the Add WMS/WMTS Layer button 

 within the Manage Layers Toolbar, or by going Layer 

→ Add Layer → Add WMS/WMTS Layer from the Menu 

bar, the Data Source Manager window pops up. Upon 

pressing New, another window pops up where you can 

enter the desired name and URL of the WMS. Enter 

“Orthophoto Tirol” as “Name” in the “Connection 

Details” and the following URL: 

“https://gis.tirol.gv.at/arcgis/services/Service_Public/ort

hofoto/MapServer/WMSServer?request=GetCapabilities

&service=WMS” and confirm by pressing OK. Back in the 

Data Source Manager, press Connect, select the layer 

with the title “Aktuell_RGB” and finish with Add (Figure 

8).  

 

Figure 8; Workflow to add a WMS layer to the project: 1. add new 
WMS; 2. connect to the service; 3. select the desired layer; 4. add layer 

Public institutions often provide a variety of geographic information 
via WMS. These include recent and historic orthophotos, hillshades, 
topographical maps and even geological maps! The URL to WMS from 
the Geological Survey of Austria can be found in Appendix 1. Despite 
the advantage of no additional consumption of computer storage, the 
drawback of WMS is that it is usually only a 2D layer without additional 
information. For example, you cannot create contour lines from a WMS 
hillshade. 

2.3. Georeferencing 

Georeferencing is the process of fitting (i.e. rotating, scaling and 
warping) maps to a CRS. This is done by marking points on the map 
where the coordinates are known and then transforming it 
accordingly.  

Scans of field maps usually lack spatial information. To 

add spatial information, you have to georeference your 

map. Therefore, you have to define the coordinates of at 

least three points within that map. Alternatively, you can 

georeference a map onto an already georeferenced map 

of the same area. 

As an example, a small, scanned field map with structural 

geological data of the project area will be georeferenced 

to the already existing layers of the project by “pinning” 

together known geographical locations. (The basemap for 

this field map was exported from tiris (2018)) 

Before georeferencing, the “Georeferencer GDAL” plugin 

(preinstalled in QGIS3) must be activated. From the Menu 

bar, select Plugins → Manage and Install Plugins. Within 

the Plugin Manager either search for “Georeferencer 

GDAL” or look for it in the installed plugins. Check the 

checkbox besides the plugin and close the Plugin 

Manager. The Georeferencer GDAL is now part of 

your toolbar, open it.  

To start, press Open Raster , load the un-

georeferenced map and select a CRS. The spatial 

information of your raster-file will be saved in that CRS. 

To add a new ground control point (GCP) (i.e.: point of 

known location) press Add Point  and click on the first 

point of the un-georeferenced map of which you know 

the location. You can now either enter known 

coordinates or select a point From Map Canvas. 

Confirm and proceed to add some known points. 
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At least three known points (even more for some types of 
georeferencing are needed. Use distinctive points like crossroads, 
summits, churches, huts etc. for georeferencing, but be careful that 
the points are the same in both maps! A coordinate grid in the un-
georeferenced map is usually the most reliable reference point.  

After you have added some points (Figure 9), open the 

Transformation Settings , choose a Transformation 

type (e.g. “Linear” for very simple transformations), 

select the project CRS as “Target CRS”, select a location 

where the georeferenced map is supposed to be stored 

and check the “Load in QGIS when done” checkbox. 

QGIS offers several other (more sophisticated) Transformation Types 
that are worth checking out in case you deal with heavily distorted 
maps (e.g.: historical maps): 

The small red lines at your GCPs will now give you a 

preview of the transformation. Start Georeferencing  

and feel free to save the GCPs (often not necessary). The 

scanned map will now appear in your map window and 

you can check whether or not it is in the correct place 

(Figure 10).  

 

Figure 9; GCPs (red points) added to a scanned field map. 

 

 

Figure 10; a georeferenced, scanned field map 

3. Step: Mapping 

On a geological map, information is presented with 

points, lines and polygons. A “shapefile” is a common way 

to save such geometries. Although the shapefile (.shp) is 

a well-established file type, it has several drawbacks. For 

example, at least three files are generated which must be 

stored together. The new main-file type in QGIS3 is the 

“geopackage” which offers the advantage that all 

information is stored in one file. Further on, it allows the 

storage of different feature-classes (point, line and 

polygon) together while shapefiles can only store one 

feature class per file. 

For additional technical information on shapefiles, see ESRI (1998). For 
geopackages, the website http://www.geopackage.org/ is 
recommended.  

3.1. Points 

Points like structural geological orientation data, springs, 

wells, geographical locations etc. can be defined directly 

within the project or added automatically from 

spreadsheets 

http://www.geopackage.org/
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3.1.1. Direct input 

As an example, some geographical locations well visible 

in the previously added orthophoto WMS layer will be 

digitized. The goal is to create a point layer with the 

geographical locations and their respective names.  

To create a new point layer, choose Layer → Create Layer 

→ New Shapefile Layer. Call the new shapefile (or 

geopackage) “geographical_location”, leave all other 

settings as they are and save the file to the vector data 

folder within your tutorial-folder (Figure 11). 

 

Figure 11; Creating a new Shapefile - point layer 

Since at least three separate files are created for every shape file, you 
may consider to further subdivide your “vector_data” folder for 
bigger projects to keep it organized (or to use the geopackage-file 
instead). 

Within the layers panel of your project, add a folder 

“Additional information” on top of everything else. Move 

the new “geographical_information” layer to this folder. 

By default, QGIS chooses a simple circle marker with an 

arbitrary color for newly added point layers. If you want 

to change the style, Right click → Properties → 

Symbology on that layer to enter the layer properties 

window. 

To add a “name” attribute to the layer Right click it and 

select Open Attribute Table. In the new window Toggle 

editing mode  and click New Field . Within the 

“Add Field” window, enter a name for the new column, 

change the type to “text” and give a sufficiently high 

number as “Length” of the field (Figure 12). 

 

Figure 12; adding a new attribute 

Safe layer edits regularly  to avoid loss of progress.  

For adding, removing, and general editing of shapefiles 

(or geopackages), the editing mode must be activated. To 

add a point to the map, press the Add Point Feature 

button  within the digitizing toolbar. After clicking the 

desired location in the map window, a small window 

appears where you can assign attributes to that feature.  

Add some geographical locations to the map (for example 

with the help of google maps or tiris (2018)) and add 

names to the features. Safe your edits and deactivate the 

layer’s editing mode. To label the layer, Right click it and 

select Properties → Labels. Change the selection to 

“Show labels for this layer”. In the drop-down menu of 

“Label with”, select the “name” attribute and press OK 

(Figure 13). 
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Figure 13; Adding labels to point layers 

Again, it is highly recommended to play with all the possibilities for 
style and label customization to find an appealing design! 

With this method, a variety of highly customizable point 

layers can be added to the map. As another example a 

layer with a font marker (instead of the simple marker) 

showing the location of springs in this area is added to the 

map. 

By now your map should look similar to Figure 14. 

3.1.2.  Importing data from text files 

Geolocated point data (e.g.: structural geological 

measurements, well locations etc.) is often stored as a 

text file which can be imported into QGIS. The advantage 

of using text files as data sources is that if the data source 

changes (e.g. new measurements are made), the point 

layer is updated within your project (when QGIS is 

restarted, or the layer is reloaded).  

As an example, some structural geological measurements 

were taken on roadcuts in the area between Höttinger 

Alm and Bodensteiner Alm. (i.e.: two huts). 

To show the orientation of planes with strike/dip 

symbols, a text file with at least four columns is needed. 

Usually an additional column with the type of the 

measurement (i.e.: bedding plane, joint, fault…) is given 

(see Table 2) and can be utilized for a classified symbology 

(see chapter 3.3 “polygons” for explanation on classified 

symbology) 

Figure 14; Map with two new point layers: geographical locations and springs 
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Table 2; example of a text-file with five columns, containing geolocated 
structural geological measurements 

longitude latitude dip 
direction 

dip type 

47.29701 11.38180 338 37 bedding 

47.29752 11.38044 158 56 bedding 

47.29739 11.38057 355 62 bedding 

… … … … … 

 

To add data from a text file either use Add Delimited Text 

Layer  within the Manage Layers Toolbar or go to 

Layer → Add Layer → Add Delimited Text Layer … from 

the Menu bar. Adjust the settings of the Data Source 

Manager | Delimited Text window to match your file 

(Figure 15) and Add the points to the map. 

 

Figure 15; Adding a delimited text layer to the project; common error 
sources labelled 1.-4. 

Common sources of confusion are (labeled 1-4 in Figure 15):  

1. unknown/wrong custom delimiters of the text file (in doubt: 
right click and open the text file with a text editor instead of 
spreadsheet applications to see what the delimiter between 
columns is) 

2. number of header lines to discard is not correct 

3. wrong columns for X- and Y- coordinates are selected, or X 
and Y coordinates are switched. If this happens, points will 
usually plot far away from their expected location and are 
90° rotated. You can check if points are located far outside 
your basemap by right clicking the new layer and clicking 

Zoom to Layer . 

4. wrong CRS is chosen for the geometry of the text file (this 
CRS does not necessarily have to fit your project CRS) 

As described above, the point layer’s symbology can be 

changed for the layer with Right click → Properties → 

Symbology. To symbolize the dip direction of the 

measurements, choose a “Font marker” instead of the 

“simple marker”. Change the “Fill”- and “Stroke color” to 

black, choose a visible size and select the letter “T” as 

symbol (Alternatively, look for a better symbol for the 

“strike/dip” symbol within your installed font-types or 

create a customized symbol) To rotate the symbol 

according to the dip direction, click the Data-defined 

override  button beside the “Rotation” input field and 

choose the name of the dip direction – column of your 

dataset (Figure 16).  

 

Figure 16; setting the symbol rotation according to the dip direction of 
the point 

By clicking Apply, your symbols are rotated, but 180° 

twisted. To correct this, choose Edit (Figure 17 (top)) and 

enter >180 + “DipDirection”< in the Expression String 

Builder (or whatever your dataset’s column with the dip 

direction is called) (Figure 17 (bottom)). If you have 

chosen a letter that is already 180° rotated, this step is 

not necessary. As a last step, choose the “Dip” column as 

label for the structural geological measurements (Right 

click on the layer, select Properties → Labels and change 

the selection to “Show labels for this layer”.).  

Instead of “font markers” also “SVG markers” can be used. Scalable 
Vector Graphics (SVG) can be created with different graphic programs 
and allow you to design your own markers from scratch. 



 

13 

 

Figure 17; Workflow to twist point layer symbology by 180° 

3.2. Lines 

To create new lines (for features like rivers, fold hinge 

lines, crowns of landslides…) go to Layer → Create Layer 

→ New Shapefile Layer and choose “Line” as the 

“Geometry Type” in the New Shapefile Window. 

To demonstrate the functionality, rivers and creeks will 

be added to the map. Toggle Editing  → Add Line 

Feature  and draw a new line by adding vertices to 

the map. Enable Snapping  and adjust its 

functionality in the Advanced Configuration  if you 

want to connect two lines (for example two creeks). To 

add labels to line features Right Click them and select 

Properties → Labels and change the selection to “Show 

labels for this layer”. By default, QGIS adjusts labels 

parallel to the line. If inappropriate, this can be changed. 

3.3. Polygons 

One kind of geological maps is the lithological map, which 

aims to show the spatial distribution of different 

lithologies. Lithologies are usually presented by closed 

polygons with a uniform symbology (i.e. one color, or one 

signature). In this tutorial, three simple units will be 

differentiated: 1. Anthropogene Cover; 2. Quaternary 

Cover; 3. Austroalpine Units. The distribution of the 

geological units was simplified after the Geofast – 

geological map of Innsbruck and derived from the DEM 

and Orthophoto data. 

To create new polygons, go to Layer → Create Layer → 

New Shapefile Layer. The “geometry type” in the New 

Shapefile Window has to be changed to “Polygon”. 

Polygons should be placed above basemaps and below 

point- or line data. 

 

Figure 18; using a categorized symbology for displaying different 
geological units 

Add a new text-column to the Attribute Table of the new 

polygon layer and term it “Geologic Unit”. With that 

column you can name each polygon according to its 

respective geological unit. To classify the polygons (i.e.: 

assign individual symbols to each unit) Right Click the 

polygon layer and select Properties → Symbology and 

select “Categorized” instead of “Single Symbol” in the 

upper part of the Layer Properties Window (Figure 18). 

Press Classify and change the symbology. 
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Whatever color you may choose for your polygons, adding 

transparency to polygons is often a good idea because it allows the 

basemap- and polygon layers to be displayed simultaneously. 

 

Add polygons to your map by Toggle Editing  → Add 

Polygon Feature  and start “drawing” by clicking the 

desired place on the map ( Figure 20). Tools like Add Ring 

 from the Advanced Digitizing Toolbar help to create 

more complex geometries. 

When you are drawing and editing polygons, always keep in mind what 

the final scale of your map is supposed to be and create your polygons 

with enough nodes/vertices for a proper, smooth looking result. 

 

 
Figure 20; creating a new polygon 

 

Figure 21; Snapping helps to fit one feature to another 

Figure 19; The map after adding point-, line- and polygon-layers. 
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Finish the new polygon by right clicking the map window 

and pressing OK in the small attribute window (like with 

points and lines you can add attributes to polygons).  

Whenever you are creating polygons adjacent to each 

other, Enable Snapping  and Tracing  to speed 

up the process and to create borders without holes and 

intersections (Figure 21). 

Avoid overlapping polygons or gaps in between. Such errors may 
cause problems later on. 

By now your map should look like Figure 19. 

4. Step: Layouts 

A “quick and dirty” way of exporting maps from QGIS is 

Save Map as Image which can be found in Project. Do not 

forget to scale the resolution accordingly. 

Anyway, a geological map needs a legend, a scale bar and 

a north arrow. To create such a map, select Project → 

New Print Layout  in the Menu bar and name your 

map layout. Upon confirmation, the Print Layout window 

opens (Figure 22). 

First, Right Click the empty page of the map window and 

select → Page Properties. Within the Item Properties 

panel, you can change the overall properties (height, 

width, orientation…) of the page. To add a new map, 

choose the Add a new Map to the layout  button 

within the toolbox and draw a boundary box onto the 

empty page. Your main map window (with all active 

layers) will now appear. The displayed map corresponds 

to the active layers in your main QGIS window. Note that 

you can add more than one map to your layout. Clicking Move 

item content  in the toolbox allows you to zoom in 

and out by scrolling and to move the whole map content 

within the boundary box. After you have found an appropriate 

scale and the right area of the map, it is recommended to lock the map 

item within the Items Panel to avoid accidental shifting of the map 

content. 

 

Figure 22; Print Layout window with several GUI elements: 1. Menu Bar; 2. Toolbars; 3. Items Panel; 4. Layout Panel (and other panels); 5. Item 
Properties Panel (and other panels); 6. Toolbox 
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Every item of the map has its own Item Properties Panel 

which can be used for manual customization. For 

example: You can choose your map’s scale (e.g.: 

1:15 000) or add features like a frame, background or 

coordinate grid. To add a grid, go to the “Grids” section 

of the Item Properties Panel of your map, click Add a new 

grid, activate Draw “Grid 1” grid and click Modify grid… 

(Figure 23) 

 

Figure 23; adding a grid to the map 

Within the Map Grid Properties, the grid itself can be 

customized and for this tutorial’s map the following 

parameters were chosen: Grid type: solid; CRS: 

EPSG:31254; Interval Units: Map Units; Interval (X,Y): 

1000,00. Do not forget to give the used CRS’s name on your map. 

Click Add a new Scalebar to the layout  and place it 

on the map. Modify the item properties to enhance 

visibility. A North arrow can either be added by combining 

a triangle shape (Add Shape ) with the letter “N” 

(Add Label ), or by inserting an image of a North 

arrow by clicking Add Picture . Add a new Legend to 

the layout  and place it accordingly. By unchecking 

“Auto update” within the Item Properties panel of the 

legend, you can manually edit the legend-content. By 

using the described tools of the toolbox, you can easily 

add additional information to your map and make it look 

more appealing. For demonstration, some additional 

labels and a stereonet (created with Stereonet 10 by Rick 

Allmendinger (Allmendinger et al., 2012; Cardozo and 

Allmendinger, 2013)) are added to the map.  

 

Figure 24; Image export options 

 

By clicking Layout → Export as Image  or Layout → 

Export as PDF  you can export the map. In the Image 

Export Options, you can choose the export resolution, if 

you want to create a world file (for georeferencing of the 

map-image) and if you want to enable antialiasing (for 

smoother graphics) (Figure 24). 

The final map is presented in Figure 1. 

 

 

 

Congratulations, you have created a geological map 

with QGIS 3! 

 

  



 

17 

Acknowledgements 

I want to thank the QGIS development team for their 

efforts of developing and constantly upgrading this 

tremendously handy piece of software. I also want to 

thank the Land Tirol for publicly offering the high 

resolution geospatial data that was used in this tutorial. 

Review and tips from Markus Palzer and Dominik Jaeger 

are greatly appreciated. 

The work of the authors of the countless tutorials and 

guides that are freely available on the internet (e.g.: 

Lorscheid (2013)) is acknowledged. 

 

 

Appendix 

Appendix 1; Data sources used in this tutorial 

Name Type Source 

5m res. digital elevation model 
Tirol 

raster data https://www.data.gv.at/katalog/dataset/land-tirol_tirolgelnde 

Orthophoto Tirol WMS https://www.data.gv.at/katalog/dataset/35691b6c-9ed7-4517-
b4b3-688b0569729a 

Geologische Bundesanstalt - 
Web Services 

WMS https://www.geologie.ac.at/services/web-
services/?R=%252Fetc 
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